Usb mic not working in Auria only

For topics specifically about audio interfaces (USB, MFi, Camera Connection Kit)

Moderators: Corey W, Rim

Post Reply
Spud
Expert
Posts: 81
Joined: Sun Sep 15, 2013 4:33 pm

Usb mic not working in Auria only

Post by Spud » Sat Nov 01, 2014 9:09 pm

I have a usb measurement mic, UMIK1, which works ok in Garageband and other recording apps. In Auria however it causes problems - I just get a faint cyclic clicking in the headphones, level meter only working for a moment, also cyclically, and no recording.

Any reason it would not work in this app only? I have tried disabling USB soft start and input monitor.

Cheers :-)

Rim
Site Admin
Posts: 7847
Joined: Fri Dec 23, 2005 11:08 pm

Re: Usb mic not working in Auria only

Post by Rim » Sat Nov 01, 2014 9:13 pm

USB and MFi devices aren't app specific. If they work in one app, they should work in all apps because the derivers are part of the operating system and apps have no control over how they work. Are you sure Auria is set to 44100 as a sample rate? Have you tried different buffer sizes? Maybe that interface doesn't like the buffer size you have set.

Rim

Spud
Expert
Posts: 81
Joined: Sun Sep 15, 2013 4:33 pm

Re: Usb mic not working in Auria only

Post by Spud » Sat Nov 01, 2014 10:45 pm

Buffer size doesn't seem to make a difference, and yes running at 44.1. I can get it to work for bit by removing and reinserting the USB conn, but it craps out again after doing a short recording then stopping it. It cyclically halts the whole app for a bit less than a second. In the input matrix it shows up as inputs on 1 and 2, if that is of any interest. Not sure if this is relevant also, from cross spectrum labs:

• The microphone may not work properly with software that expects the input device and output device to share the same clock source (for example, ARTA has issues when averaging multiple measurements with the UMIK-1).

Cheers Rim.

Rim
Site Admin
Posts: 7847
Joined: Fri Dec 23, 2005 11:08 pm

Re: Usb mic not working in Auria only

Post by Rim » Sun Nov 02, 2014 5:30 am

Not sure what to suggest. Anything dealing with the clock is all handled by iOS, and is not controllable by apps. Apple simply provides the audio to an app, and there's no way for an app to really affect how a USB or MFi device behaves.

Are you using an iPad 2,3,or original mini? If so, this might be the Core Audio bug that's been talked about in other posts. But this only affects those models.

Rim

Spud
Expert
Posts: 81
Joined: Sun Sep 15, 2013 4:33 pm

Re: Usb mic not working in Auria only

Post by Spud » Mon Nov 03, 2014 4:03 pm

Ipad 4. Cheers anyway, will have to remain a mystery!

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 3 guests