Rode ixy

For topics specifically about audio interfaces (USB, MFi, Camera Connection Kit)

Moderators: Corey W, Rim

Post Reply
danblade77
Member
Posts: 14
Joined: Sat Oct 12, 2013 5:27 am

Rode ixy

Post by danblade77 » Sat Feb 22, 2014 5:13 am

Hi,

Yesterday I was using my Rode ixy in Auria to track n acoustic guitar idea. I couldn't seem to get a very good recording level though. I adjusted the input level but this didn't seem to make any difference. Is there something I'm missing as I tried in garageband to double check and when the recording level was adjusted it worked fine.

Many thanks,

Dan

danblade77
Member
Posts: 14
Joined: Sat Oct 12, 2013 5:27 am

Re: Rode ixy

Post by danblade77 » Sat Feb 22, 2014 3:38 pm

Sorted now, needed setting up in Rode rec app first :)

User avatar
mtingle
Expert
Posts: 990
Joined: Sun Aug 05, 2012 3:47 am
Location: Cornwall, UK

Re: Rode ixy

Post by mtingle » Mon Feb 24, 2014 12:01 pm

it seems to be completely random for me.

sometimes I plug in the iXY open the Rode app and the signal is there and nice and strong however,

more often than not there is a *VERY* weak signal (source is exactly the same) or,

it doesn't work at all, nothing.

The rode app is IMO a complete piece of junk with so many bugs it's just a laughable (unusable) joke.

danblade77
Member
Posts: 14
Joined: Sat Oct 12, 2013 5:27 am

Re: Rode ixy

Post by danblade77 » Sun Mar 02, 2014 6:35 am

Yeah, I must admit I've only tried it a couple of times, first time hardly any input signal. The second time really good input signal. Going to keep experimenting with it.

User avatar
Tarekith
Expert
Posts: 237
Joined: Sat Apr 27, 2013 10:29 pm
Location: Luxembourg
Contact:

Re: Rode ixy

Post by Tarekith » Sun Mar 02, 2014 10:25 am

It's a shame Rode bought the app from Audiofile Engineering instead of letting them manage it, would likely not have so many bugs :(

BGR
Expert
Posts: 81
Joined: Fri Oct 11, 2013 10:14 am

Re: Rode ixy

Post by BGR » Mon Mar 03, 2014 6:03 pm

Tarekith wrote:It's a shame Rode bought the app from Audiofile Engineering instead of letting them manage it, would likely not have so many bugs :(
The original iXY firmware was also quite buggy. I exchanged mine for another interface after a failed firmware update.

And I had the original Fire2 App. Before Rode bought it. It was fantastic and never failed. "Updated" to Rode App and I regret the decision. I uninstalled Rode App. And now I can't download Fire2 again.

I personally would not recommend the Rode iXY to anyone that is looking for good sounding clean audio that you can record anytime anywhere. After doing some tests with it, I decided to keep using my Tascam IM2 instead. Easier to use, lighter and has not failed me yet. The iXY failed to be recognized 4 out of 5 connection tries -original firmware-.

Don't get me wrong, I like Rode Mics. I just think that they did a terrible job with the iXY.

Post Reply

Who is online

Users browsing this forum: Baidu [Spider] and 2 guests