Focusrite Scarlett 2i2 issues

For topics specifically about audio interfaces (USB, MFi, Camera Connection Kit)

Moderators: Corey W, Rim

Post Reply
Guff Golgotha
New Member
Posts: 3
Joined: Wed Jun 12, 2013 11:20 pm

Focusrite Scarlett 2i2 issues

Post by Guff Golgotha » Thu Jun 13, 2013 4:27 pm

If you are trying to use the Focusrite Scarlett 2i2 to record into your iPad, you MUST use a powered USB hub such as the Dynex 2.0-7 or you will get an error message saying the USB device requires to much power. The key seems to be not the voltage, but the amperage output needed to drive the high end preamp (96khz/24bit) in the Focusrite interface. The Dynex hub puts out 3.5 amps and runs the Focusrite perfectly and the sound quality is absolutely amazing. I highly recommend this set up for Auria. I do wish this info had been available on either Auria's site or Focusrite's as it would have saved me hours of frustration.

User avatar
djjuniorpops
Expert
Posts: 140
Joined: Wed May 08, 2013 10:43 am

Re: Focusrite Scarlett 2i2 issues

Post by djjuniorpops » Sun Aug 25, 2013 10:38 pm

I quite agree with you, I am using the same set up at the moment with my iPad and it sound amazing.

fgplayerx
Expert
Posts: 21
Joined: Sun Sep 29, 2013 12:12 pm

Re: Focusrite Scarlett 2i2 issues

Post by fgplayerx » Thu Oct 10, 2013 2:09 am

I use the 2i2 with a 800mA mobile phone external battery power supply. And it runs smoothly with 2 phantom powered condenser mics. You don't need so much power to run the 2i2 or the iTrackSolo.
Unless, ofcourse, you'r trying to charge your iPad in the process.
But for the interface itself, not so much power is needed.

spuds0828
Member
Posts: 19
Joined: Fri Oct 25, 2013 8:12 am

Re: Focusrite Scarlett 2i2 issues

Post by spuds0828 » Mon Nov 18, 2013 4:00 pm

I just got the dynex 2.0-7 hub and i plug it all in and i get no data transfer from the interface to the ipad or vice versa...when i press play on auria the music come out of the ipad and not the interfaces headphone out like it should...any suggestions....do your interfaces still work with auria since the update or so on....trying to get this figured out!!!

spuds0828
Member
Posts: 19
Joined: Fri Oct 25, 2013 8:12 am

Re: Focusrite Scarlett 2i2 issues

Post by spuds0828 » Mon Nov 18, 2013 4:16 pm

djjuniorpops wrote:I quite agree with you, I am using the same set up at the moment with my iPad and it sound amazing.
does it have all the ports...on the side...or is it the one that has the 3 ports on top and 4 ports on the side?

User avatar
djjuniorpops
Expert
Posts: 140
Joined: Wed May 08, 2013 10:43 am

Re: Focusrite Scarlett 2i2 issues

Post by djjuniorpops » Mon Nov 25, 2013 5:42 am

It's a 4 port with 3 on the side and 1 on top

Katherine_Focusrite
Expert
Posts: 48
Joined: Mon Aug 12, 2013 4:37 pm

Re: Focusrite Scarlett 2i2 issues

Post by Katherine_Focusrite » Thu Dec 05, 2013 4:54 pm

Hi djjuniorpops,

If you are able to get the 2i2 to power on, which you can tell because pressing the 48v button it goes red, you may have another connection issue.

Can you check the connection of the Apple Camera Connection Kit, make sure it is the Apple Branded one, some third party ones do not work well. You may also check other USB cords as one could be faulty.

Additionally can you test this 2i2 out on your computer.

If you need any further assistance please feel welcome to contact us directly: http://us.focusrite.com/answerbase/contact

Best regards.
Katherine Kaplan // Focusrite Technical Support

http://www.focusrite.com/answerbase/en/

stanley82
New Member
Posts: 1
Joined: Wed Jan 29, 2014 1:05 am

Re: Focusrite Scarlett 2i2 issues

Post by stanley82 » Wed Jan 29, 2014 1:13 am

Hi guys,
I have issue with this soundcard in terms of connection to ipad 2 ios 7.0.4. The problem is that it works ok except the soundcard is somehow "restarting" itself periodicly. Very similar to behaviour during switching apps. Soundcard turns off itself for 1s and then start blinking in this sequence:

1. one blink
2. 3 blinks
3. 4 blinks

Do you have idea what is it about?
Thank you

Katherine_Focusrite
Expert
Posts: 48
Joined: Mon Aug 12, 2013 4:37 pm

Re: Focusrite Scarlett 2i2 issues

Post by Katherine_Focusrite » Thu Jan 30, 2014 6:17 pm

Hi Stanley82,

What light is blinking? If it is the USB green light this is indicating a driver connection, so possibly the iPad is reengaging the driver when switching programs.

Does closing all programs and then opening them again help? Does resetting the iPad with the Home and Power button help?

Does the same interface do this on another iPad? I have not seen it before.

Can you test the interface on a computer to make sure the USB port is working well there?

You may want to try Backing up and restoring the iPad incase there is any CoreAudio Driver issue going on.

Please let me know how it comes along.

Kat
Katherine Kaplan // Focusrite Technical Support

http://www.focusrite.com/answerbase/en/

BGR
Expert
Posts: 81
Joined: Fri Oct 11, 2013 10:14 am

Re: Focusrite Scarlett 2i2 issues

Post by BGR » Mon Feb 10, 2014 5:14 am

@Katherine_Focusrite @stanley82

I have exactly the same problem as @stanley82.

I used to work on a iPad Mini. With the same problems while working with the 2i2.

And now I have a iPad 4 retina A6. And the 2i2 behaves exactly the same as before.

I really like the sound I achieve from the 2i2. That is why I still have it. But it is quite annoying sometimes because it happens randomly and sometimes while recording.

@stanley82, you're not alone :)

Btw, ipad software version is 7.0.4

EDIT: I must also add that my issues with the 2i2 also happen while using MultitrackDAW from HarmonicDOG. Meaning in my point of view, that it is not Auria related. But maybe iOS or hardware related.

Katherine_Focusrite
Expert
Posts: 48
Joined: Mon Aug 12, 2013 4:37 pm

Re: Focusrite Scarlett 2i2 issues

Post by Katherine_Focusrite » Thu Feb 20, 2014 8:06 pm

Hi BGR,

This does sound more than an issue from the iPad Driver or Hardware.

The green light in no way indicates the unit is not powered.

For example using any of our Scarletts in Standalone Mode they will never have a USB light on, as there is no USB connected, but they pass audio and work as Line Mixers.

If you can hit the 48v red the unit is powered.

The Green light indicates the driver is connected.

Can you test your 2i2 on a computer to ensure a good connection there?

Can you try another USB cable or CCK? These could be wobbly or becoming faulty?
Katherine Kaplan // Focusrite Technical Support

http://www.focusrite.com/answerbase/en/

BGR
Expert
Posts: 81
Joined: Fri Oct 11, 2013 10:14 am

Re: Focusrite Scarlett 2i2 issues

Post by BGR » Tue Feb 25, 2014 3:05 am

I had been powering my 2i2 with a Y cable connected to a passive USB hub and a mobile phone charger.

The charger output 5V, 800mA Maximum. And my 2i2 was reseting randomly.

I changed the mobile charger to one that outputs 5V, 2.1A. And the 2i2 has worked smoothly after that. It has not reset after that.

It might be a powering problem.

If it is a powered USB hub, the power supply might be faulty. Or not stable enough. Or you should try a higher output power supply.

If it is a passive USB hub, a Y cable and a mobile phone charger, then search for a good quality charger with higher output. Maybe 1.5A or more.

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 1 guest