Midi Join Bug

For bug reports only - non-bug related questions will be moved to appropriate forum.

Moderators: Corey W, Rim

Post Reply
User avatar
-ki
Expert
Posts: 61
Joined: Mon Jan 12, 2015 4:49 pm
Location: Berlin

Midi Join Bug

Post by -ki » Mon Oct 16, 2017 3:21 am

iPad Pro 10.5 IOS 11.0.3 AuriaPro 2.13

I found two bugs with midi join:
  • either the first note of left joined part is missing (all notes that are at the very beginning of the region)
  • or the whole first region is missing and the second region is moved to the start of the joined regions

How to reproduce:

1) New project, add a midi track
1_AddMidiTrack.jpg

2) Add 4 notes in the midi editor - i added 4 different quarter notes in the first bar, each at a beat
2_AddNotesInEditor.png

3) Split at the third beat
3_SplitRegion.jpg

4) Move first region to the beat behind the second one
4_MoveFirstRegion.jpg

5) Select both regions and join.
=> ERROR: The first note will be missing.
5_Join_And_FirstNoteIsMissing.jpg



To reproduce the second midi join bug:

Either undo the last step or start from scratch and redo steps 1 to 4.

5B) Addionally enlarge the first region to the beat
5b_EnlargeFirstRegion.png

6) Select both regions and join.
=> ERROR: The first region is skipped and the second region moved forward.
6_Join_And_SecondRegionIsMoved_FirstIsMissing.jpg
I hope these instructions help in fixing these two midi join bugs.

User avatar
-ki
Expert
Posts: 61
Joined: Mon Jan 12, 2015 4:49 pm
Location: Berlin

Re: Midi Join Bug

Post by -ki » Mon Oct 16, 2017 8:48 am

I just encountered another outcome of the Midi Join Bug.

1) Create a new project, add midi track
2) Add the four notes each at at beat using the grid (as above)
3) Split at beat 1:4 (like before)
3b_SplitRegion.jpg

4) Multi-select both regions and join
=> ERROR: Third note is shrunk and fourth note missing
4b_Join_And_Note3ShrunkAndNote4Missing.jpg


BTW: The Auria bugzilla only shows an '500 Internal Server Error', otherwise i would have added these bug directly to the bug tracker

Rim
Site Admin
Posts: 7845
Joined: Fri Dec 23, 2005 11:08 pm

Re: Midi Join Bug

Post by Rim » Mon Oct 16, 2017 9:40 am

Thanks. I just fixed this. It's been on the list for a while - thanks for reminding me.

Rim

User avatar
-ki
Expert
Posts: 61
Joined: Mon Jan 12, 2015 4:49 pm
Location: Berlin

Re: Midi Join Bug

Post by -ki » Mon Oct 16, 2017 11:18 am

Cool, thanks a lot for the fast fix :D

Post Reply

Who is online

Users browsing this forum: Baidu [Spider], Yahoo [Bot] and 1 guest