Auria Pro is crashing when I press record

For bug reports only - non-bug related questions will be moved to appropriate forum.

Moderators: Corey W, Rim

Post Reply
Sound Wavy Davy
Member
Posts: 6
Joined: Sun Apr 23, 2017 6:44 am

Auria Pro is crashing when I press record

Post by Sound Wavy Davy » Tue Aug 29, 2017 2:23 am

Auria Pro Version: 2.11 is crashing when I press record…

I have the regular version of Auria, upgraded to Auria Pro Version2.11, using in app purchase.

I have an iPad air Model MF015LL/A (120 Gig), running iOS 10.3.3 (14G60), with 48 GB of free space available.
I recently Erased all content and settings on it, then reinstalled everything.
Before I did this, Auria pro seemed to be working most of the time, with only the occasional crash and or freeze.
After I did this, Auria Pro crashes every time I arm tracks, press record, then press play, to start recording.

It has happened repeatedly, even after complete reset of the iPad (holding both the home and off button down, until it resets and apple appears).
Recording one mono, and one stereo audio tracks, no MIDI.
I never record more than 4 tracks at a time, using a Focusrite Scarlet 18i8 (first gen)
I don’t record using effects, or with other apps running. Record buffer size is set to 512. Not using 64-bit mixer.
I put iPad in”airplane mode” and “Do not disturb mode" when recording.

My next troubleshooting step will be to uninstall Auria, then reinstall, test, then upgrade to Auria Pro, by recovering my Pro upgrade using the “restore in app purchase” dialog in Auria Store, in the Menu.
After restarting iPad and reinstalling Auria-Mobile Music Production, I tested the record capability (using the iPad’s built in mic), and it worked without crashing.
After recovering/installing my Auria Pro upgrade, it was unable to record, and would crash each time I enabled a track, hit record, then play.
I have deleted Auria Pro, and will reinstall Auria-Mobile Music Production, without installing the Pro upgrade, until you contact me and explain why the Pro upgrade makes the software unable to record audio, and provide me with a solution for getting the Pro upgrade to work again.
Hope you are doing well, and to hear from you soon, to fix this problem.
Thanks
Dave

Rim
Site Admin
Posts: 7900
Joined: Fri Dec 23, 2005 11:08 pm

Re: Auria Pro is crashing when I press record

Post by Rim » Tue Aug 29, 2017 6:15 am

There's nothing I can think of that would cause your Auria installation to crash when you press record. Are you trying this using a new project, or an existing project? If you create a brand new project, add one track, press the record enable button for that track, then press record and play, does it crash?

Rim

Sound Wavy Davy
Member
Posts: 6
Joined: Sun Apr 23, 2017 6:44 am

Re: Auria Pro is crashing when I press record

Post by Sound Wavy Davy » Tue Aug 29, 2017 6:53 pm

Hi, Rim.
Thanks for the quick reply.

Yes, this is with a fresh (new) project with it's default name.
As per my previous post, Auria records without crashing, until I do the Auria Pro upgrade (restored from an earlier purchase, through the in app store).
After upgrading to Auria Pro, it is not able to record, and crashes, when I start a new project, arm two tracks and press record, then Play.
This has happened repeatedly.
It used to work, before I recently deleted all the apps/content on my iPad, and restored from an iCloud backup.

I am backing everything up on the iPad and planning to delete all iPad content, then reinstall the most current iOS iPad operating system (from iTunes), then restore Apps and other content from iTunes or iCloud backup.
Will report if this fixes the problem.

Yes this is a strange failure mode, and particularly nasty as it gave no clue I was in trouble, until I was at a live gig, then crashes when the music starts, and I hit record :-(
Had to quickly start another multi track recording app (named "MultiTrack"), to save the day, and capture the rest of the evenings performance.
Fortunately it was not the most important performance, so no big deal missing the first few songs.

Thanks again for your help sorting this out.
Let me know if I can provide you with any additional information that would give you a clue as to what is going wrong.
I would like to get the Pro level working again, as soon as is practical.
Best wishes
Dave

Rim
Site Admin
Posts: 7900
Joined: Fri Dec 23, 2005 11:08 pm

Re: Auria Pro is crashing when I press record

Post by Rim » Wed Aug 30, 2017 3:03 pm

Auria and Auria Pro use the same source code, so it's puzzling to me that there would be any difference between the two in terms of recording issues. Also, I've never had an issue like this reported before, so it's really throwing me for a loop. Recording is not something I've had people report issues about.


A couple of things to try:

- In the settings page, go to the record tab and disable the "Draw Waveforms While Recording" option to see if that makes a difference.

Also, try playing with the various other settings on the record tab.

Does the same issue happen without your audio interface plugged in? In other words, recording the iPad's built-in mic? Maybe it's an issue with the camera adapter or a cable?

Rim

Sound Wavy Davy
Member
Posts: 6
Joined: Sun Apr 23, 2017 6:44 am

Re: Auria Pro is crashing when I press record

Post by Sound Wavy Davy » Thu Aug 31, 2017 3:36 pm

Problem Solved. Can't use forward slash "/" in track names.
When I use the forward slash in a track name, Auria crashes when you press play, after arming tracks, and pressing record.

Also seems I needed to install a fresh version of the iPad's operating system, then reinstall all the apps etc, from a backup.
Auria seems to be working well now, as long as I don't use a backslash in the track names.
Wonder if there is any other punctuation marks etc, that would not work in the track name dialog box.
It would be nice to have a software fix for this, so you can't crash the system that way✌️

Best wishes
Dave

Rim
Site Admin
Posts: 7900
Joined: Fri Dec 23, 2005 11:08 pm

Re: Auria Pro is crashing when I press record

Post by Rim » Thu Aug 31, 2017 8:06 pm

Thanks for letting me know, glad you figured out what was going on. I've fixed a similar issue with project names, but wasn't aware this also existed for track names. I'll add it to the list to fix.

Rim

Said8ted
Member
Posts: 5
Joined: Fri Oct 27, 2017 6:31 pm

Re: Auria Pro is crashing when I press record

Post by Said8ted » Sun Dec 03, 2017 6:03 pm

That’s awesome. Thank you!

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests