Lost song on Update

For bug reports only - non-bug related questions will be moved to appropriate forum.

Moderators: Corey W, Rim

Post Reply
timmyg
Expert
Posts: 91
Joined: Fri Nov 23, 2012 5:54 am

Lost song on Update

Post by timmyg » Fri Nov 01, 2013 7:15 am

Hi,

I just updated to the latest version of Auria. I went to load one of my songs and the lenght is 0 with 0 tracks.
The project is completly empty. I tried loading a snapshot from before the update (they say they have 25/30 tracks) and when loaded they have nothing too.

I checked the project folder and the audio files are there but the Auria project itself is empty. Why on earth did this happen?

Is there a way to get the Auria file back with my mix intact?
What about a back-up I did a while ago via iTunes sharing to my external drive? Can I restore somehow this way.

I won't be able to replicate the song again - that's impossible.

Any help would be appreciated

Rim
Site Admin
Posts: 8107
Joined: Fri Dec 23, 2005 11:08 pm

Re: Lost song on Update

Post by Rim » Fri Nov 01, 2013 7:52 am

Sorry to hear about that. It's hard to say why this happened. What was the last thing you did with that particular project? It's rare, but possible to get a project corrupted if you force quit Auria while it was saving the project. Is this a possibility?

If you have snapshots, you should be able to restore your project. The first thing I would suggest is to make a backup of the entire project folder now, in case you overwrite something while trying to restore.

Does the corrupt project open, but with no tracks, or do you get an error while loading? Does it have the name of your project at the top, or is it "Project 1"?

Once you make a backup, I suggest trying all the snapshots to see if any of them work.

You can also try manually copying one of the snapshot files into the project folder and renaming it to the name of the project (for example test.prj)

Rim

timmyg
Expert
Posts: 91
Joined: Fri Nov 23, 2012 5:54 am

Re: Lost song on Update

Post by timmyg » Fri Nov 01, 2013 9:03 am

Hi Rim,
I can't say if I quit Auria while saving but I don't think so.

I tried all the snapshots (they say they have track length & 28 tracks) and they are all blank.

The project opens with no message.

There is no name at the top; neither 'my song title' or 'Project 1'. Just an empty space where the title normally resides.

I looked at the project folder and all of the backups and snapshots are today's date and are 111mb in size.

I tried renaming the backup files and copying them in to the project but to no avail.

Any other routes to try?

Rim
Site Admin
Posts: 8107
Joined: Fri Dec 23, 2005 11:08 pm

Re: Lost song on Update

Post by Rim » Fri Nov 01, 2013 9:23 am

Are you sure the snapshots are 111MB in size? That would be really unusual, as projects (and snapshots) are usually well under 1 MB (they don't contain audio). The fact that they're all with today's date is also odd. Auria only creates snapshots every 10 minutes (and only when you touch something like a fader). How many snapshots do you have and how long did you have this empty project open?

If you send me the project, I can take a look at it. You can send it to my dropbox: rim at drumagog dot com

Rim

timmyg
Expert
Posts: 91
Joined: Fri Nov 23, 2012 5:54 am

Re: Lost song on Update

Post by timmyg » Fri Nov 01, 2013 11:36 am

Hi Rim,

Sorry my mistake, the snapshots are 111kb in size and 4 are todays date, (probably from when I was trying to figure out what happened) and there are 8 more from various dates - these would be ideal if they had the data in them.

The backups are also 111kb but are all todays date. I only had the emptynproject open for a few minutes maybe 3 times today while figuring out.

Am I able to install the previous version of Auria I had?

I've sent you the project to your dropbox, only thing is the files are taking ages to upload my end.

Rim
Site Admin
Posts: 8107
Joined: Fri Dec 23, 2005 11:08 pm

Re: Lost song on Update

Post by Rim » Fri Nov 01, 2013 12:39 pm

I found a problem with the snapshot loading system that prevented loading of snapshots if the project had zero tracks and had a blank name (which happened in your case because the project was corrupt). I fixed this in the next version, but in the mean time you can get around this by manually copying the one of the snapshot files into your main project folder and renaming it to the name of your project (in your case Flower.prj).

Rim

timmyg
Expert
Posts: 91
Joined: Fri Nov 23, 2012 5:54 am

Re: Lost song on Update

Post by timmyg » Sun Nov 03, 2013 9:06 am

Thanks Rim. That worked a treat, you're a life saver!

timmyg
Expert
Posts: 91
Joined: Fri Nov 23, 2012 5:54 am

Re: Lost song on Update

Post by timmyg » Tue Nov 05, 2013 8:35 am

Hi Rim,

The same thing happened to me again today on a different song. It is to do with the audio copy/paste function from Beatmaker 2. I tried to audio paste a sound into Auria from Beatmaker 2 and I got a message saying the project is a different sample rate - then the project opened blank the same as Friday.

I can take the same steps as before by taking a snapshot from the folder, renaming it with the project name and deleting the corrupt project.

Rim
Site Admin
Posts: 8107
Joined: Fri Dec 23, 2005 11:08 pm

Re: Lost song on Update

Post by Rim » Tue Nov 05, 2013 8:41 am

Thanks for letting me know. This will help me find the cause of this bug, and hopefully it'll make it into the next update.

Rim

timmyg
Expert
Posts: 91
Joined: Fri Nov 23, 2012 5:54 am

Re: Lost song on Update

Post by timmyg » Tue Nov 05, 2013 1:49 pm

Hi again Rim,

I accidently deleted the project folder in iTunes file sharing while trying to replace the project file. Now I can't seem to drag or 'add' the copy I have on my PC. Could you let me know how I can get the project folder back in to Auria via file sharing or is there another way?

Thanks,

Rim
Site Admin
Posts: 8107
Joined: Fri Dec 23, 2005 11:08 pm

Re: Lost song on Update

Post by Rim » Tue Nov 05, 2013 1:53 pm

iTunes isn't a good way to transfer projects - the PC version doesn't allow folders to be copied back to the iPad. I suggest a free program called iFunBox. It's a lot easier to use and supports folders.

Rim

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest