moving clips when snap is turned off

For general questions or discussion of Auria.

Moderators: Corey W, Rim

Post Reply
User avatar
mtingle
Expert
Posts: 1019
Joined: Sun Aug 05, 2012 3:47 am
Location: Cornwall, UK

moving clips when snap is turned off

Post by mtingle » Tue Aug 21, 2012 3:22 pm

when you have snap turned off and you'd like to move a clip just a fraction, you tap and hold the clip, it turns red and then you try to shuffle it just a little to the left (or right) and it doesn't move! you have to move it a 'minimum distance' before it jumps into action leap frogging over the place you wanted to move it to. could the 'minimum distance' be either removed altogether or reduced?

trying to do exact shuffling of clips is a bit hit and miss at the moment due to this sudden initial jump.

Rim
Site Admin
Posts: 8092
Joined: Fri Dec 23, 2005 11:08 pm

Re: moving clips when snap is turned off

Post by Rim » Tue Aug 21, 2012 5:03 pm

This built-in "snap" you're experiencing is actually an iPad feature, not something Auria is doing, believe it or not. The same issue comes up when trying to move a fader a tiny amount.

There's an easy workaround on the editor for precise positioning. Just position the cursor (timeline) to exactly where you want to move the region to (zoom in if you want to get it exact). Then, set the snap mode to "Cursor", and move the region. It'll snap to your exact position.

Rim

User avatar
mtingle
Expert
Posts: 1019
Joined: Sun Aug 05, 2012 3:47 am
Location: Cornwall, UK

Re: moving clips when snap is turned off

Post by mtingle » Tue Aug 21, 2012 5:11 pm

ah ok cool, thanks Rim :)

User avatar
mtingle
Expert
Posts: 1019
Joined: Sun Aug 05, 2012 3:47 am
Location: Cornwall, UK

Re: moving clips when snap is turned off

Post by mtingle » Wed Aug 22, 2012 2:27 pm

upon further investigation Rim, it appears it is a choice that is happening within Auria as if you try to move the handle of a region with no snap it smoothly moves as your finger moves. try the same region but this time touch hold and then try to move it and it will do the sudden lurch.

This jumping for moving regions is independent of zoom level, but is perhaps easier to see when zoomed in.

Would be good for editing if this could be smoothed out.

Rim
Site Admin
Posts: 8092
Joined: Fri Dec 23, 2005 11:08 pm

Re: moving clips when snap is turned off

Post by Rim » Wed Aug 22, 2012 4:19 pm

OK, you're right. I just tried it. It's not the effect I was talking about. I'll add this to the 1.03 list.

Thanks,
Rim

User avatar
mtingle
Expert
Posts: 1019
Joined: Sun Aug 05, 2012 3:47 am
Location: Cornwall, UK

Re: moving clips when snap is turned off

Post by mtingle » Fri Dec 07, 2012 6:49 pm

updated to 1.04 and (cue drum roll) I can now move regions without the 'initial jump' after pressing and holding a region for a short moment.

Thanks Rim this makes editing a whole lot easier :)

Post Reply

Who is online

Users browsing this forum: No registered users and 9 guests