Drums XD crashes in auria pro

For general questions or discussion of Auria.

Moderators: Corey W, Rim

Post Reply
R&M
Member
Posts: 17
Joined: Thu Jan 14, 2016 12:00 pm

Drums XD crashes in auria pro

Post by R&M » Fri Jan 15, 2016 6:41 pm

I have Drums XD on an iPad Air 2 connected to an alesis dm10 edrums kit thru an iconnect audio 4+ interface. Everything works great stand alone but when put in to auria pro it crashes about every minute. I have tried it as an fx input as well as thru audiobus. All buffers, sample rates and bitrates are good. These 2 apps don't play well together . Any fixes?

Radside
Expert
Posts: 71
Joined: Sat Oct 31, 2015 1:07 pm

Re: Drums XD crashes in auria pro

Post by Radside » Fri Jan 15, 2016 9:38 pm

I suggest reading the iconnectivity forum. Their products had some issues with ios9 and I don't think there was a fix yet. The work around" as I call, was to make sure the iconnect unit was set as the clock master and to use only one host at a time.

R&M
Member
Posts: 17
Joined: Thu Jan 14, 2016 12:00 pm

Re: Drums XD crashes in auria pro

Post by R&M » Fri Jan 15, 2016 9:43 pm

I don't think it's the interface. I have the clock set to usb 1. As I said everything works stand alone until it goes thru Auria pro. I am finding the new midi support in the program is still very buggy. I normally use Logic Pro X and am pretty good with it and it's midi environment. I went with auria recently because of the mobility it presents being an iOS app but the midi side of it is still unstable. The midi channel and port selection controls in the midi control of an inst channel strip don't even function. You can see the ports and different channels and select them but nothing happens except in the text boxes themselves. No port or channel routing actually occurs.

Radside
Expert
Posts: 71
Joined: Sat Oct 31, 2015 1:07 pm

Re: Drums XD crashes in auria pro

Post by Radside » Sat Jan 16, 2016 6:43 am

Have you tried the input matrix? Page 19 of the manual talks about it. I'm still learning my way as well.

R&M
Member
Posts: 17
Joined: Thu Jan 14, 2016 12:00 pm

Re: Drums XD crashes in auria pro

Post by R&M » Sat Jan 16, 2016 11:29 am

After turning off the lighting effects in drums XD and selecting "multiple" in the settings menu in auria, no more crashes. I don't know exactly what it did but it works now. Still can't get auria to use different midi channels or ports for external midi keyboard controllers other than "All" or channel 1. No input recognized if selecting a device on channel 2 or greater. What is interesting though, inside drums XD I have it set to channel 10 and it works without triggering any other midi instruments. So I am guessing that the channel and port selections for external midi controllers don't work for internal auria midi instruments (i.e. Lyra etc.).
I am running a guitar (audio in then routed to usb) thru Tonestack, Alesis DM10 edrums (usb) thru Drums XD, an M-audio axiom air 25 (usb) to an Auria internal Lyra inst, and a Yamaha keyboard (midi din) to a different Auria internal Lyra inst. All connections going thru an iconnect audio 4+ interface. Everything works except the axiom and Yamaha trigger both Lrya instruments even when choosing the appropriate controller input port. Sound is only produced when selecting either channel all or 1. If I select any other channel except all or 1 for either controller then nothing from the controller that's on say channel 2. I tried routing one controller thru Thor on a channel 2, but Thor does not work well with others. Maybe a different synth app, I dunno.
When I run this setup into Logic, I can seperate the midi controller inputs to different instruments by selecting their input ports and assigning a midi channel in it's midi environment settings.
I am only guessing here but I don't think Auria's internal midi sequencing understands different ports or channels. It's all, 1 or nothing. Again, I dunno.

R&M
Member
Posts: 17
Joined: Thu Jan 14, 2016 12:00 pm

Re: Drums XD crashes in auria pro

Post by R&M » Mon Jan 18, 2016 10:22 am

Ok, dummy here! I completely misspoke about the ports and channels having problems with external controllers on different tracks in auria. I FORGOT to change the midi out channels on the external controllers themselves. Duh! Anyway it all works now. Ext controller 1's output on channel 1, ext controller 2's output on channel 2, dm10 controller on channel10 out (it's default), then assign the appropriate input ports and channels to to each inst track if using auria internal inst's in the midi controls or to the IAA inst's input port and channel in it's midi controls.
I found that assigning the instruments in the auria track via the FX control inserts more stable and less latency than thru the audiobus method. Less overhead I guess. I was getting complete dropouts and had to reboot everything when going thru audiobus. Maybe when everything finally goes AU instead of IAA, things will become even more stable. Also when using Thor either way, it caused a loss of audio out from everything after a few minutes. So did drums XD. No problems with Tonestack or Sunriser. I don't know if this is an iOS 9 issue but I noticed that even after closing Thor and Drums XD, they continued to run in the background but you could not see them. I saw this by launching Midibridge and they showed up as active even though they were closed. After a full shutdown and restart of my iPad, I reopened Midibridge and they were no longer available until opening them again. This does not happen with any other apps I have installed and they are the only ones that cause problems. Hmm.
Anyway, Rim you have created a great app in auria pro. Thanks

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests